Review New to Club, things I've found out so far... - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > 2006-2012 Eclipse (General 4G)

2006-2012 Eclipse (General 4G) General discussion and information about the 2006-2012 (4th Generation) Eclipse.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old April 17th, 2017, 08:19 PM   #1 (permalink)
Member
 

Name: Dan
Join Date: Apr 2017
Location: Vancouver
Vehicle: 2008/Eclipse/GT/3.8L V6
Posts: 41
Rep Power: 1
danikorea is on a distinguished road
New to Club, things I've found out so far...

I just wanted to share my experience with the club so far as I am madly falling in love with my car everyday.

-Learned how to install AUX cable. Bought it for $16 CAD off ebay and successfully installed it. I drew my cord out to the driver side and tucked everything in nicely. cord is long enough to reach driver side door where I have my phone holder on the little window and long enough to reach passenger side in case of a new girl friend.
=Did not even know my car had AUX function until I joined the club.

-My car was GT-P.
=Didn't even know

-9 speakers mystery. I only counted 6 plus sub, so 7 in total. Found out they count door speaker as 2. I still don't understand why they count that as two. Why put a speaker inside a speaker? Speakerception it is.
=Didn't even know.

-I had 17" wheel all this time when it was supposed to come with 18". Now I am searching everywhere for OEM 18" though I like the look of 17" as painted black, it resembles cop cruisers.
=Didn't even know.

-I'm supposed to (?) have two 12v outlet. Some said after 2007, they took it out. I have one by climate control and nothing inside center compartment. Just a black plastic circle cover. Will pop it this week and see if everything is prewired so I can install 2nd 12v outlet. Hope it doesn't drain battery
=Didn't even know.

-Found owners manual online. My owners manual in my car was in French for some reason. I could not read any so only looked at pictures to figure out what it was saying. Now I printed off entire English version and read all of it. I know how my car works
=Didn't even know I could get these online.

-Found service manual online. I did not know such thing as "service manual" existed. I've printed off about half (couple hundred pages) and read entire service manual. I know my car a little better now.
=Didn't even know.

-I found out that I was missing a left side Front Axle No.1 Crossmember nut and bushing. uh...yea I didn't have it. Found out while reading service manual under my car. Went to autowrecker, yanked it out and installed it.
=Didn't even know.

-I was missing more shit. No front air guides, undercovers, wheel covers, seat rail cover, nuts and bushing here and there, etc. Yea...I drove it like this for over a year all happy gogo. Again, went to autowrecker and yanked everything out.
=Didn't even know.

-My speedo was off by 10km/hr +. Didn't even know why and didn't try to fix it when I got the car. Now I know it may be due to the 17" rim I have. If not whatever. At least it puts me at ease that many people had same questions about our cars.
=Didn't even know.

-There are so many mods I can do to my car to enhance the look or performance. Im not a car guy. My car came with an aftermarket exhaust that my mom and my dog said it was too loud, black aftermarket spoilers, black rims and blue painted calipers. I drove it as it because I didn't really care, but now I know my car is cool.
=Didn't even know what "mod" is.

-I had auto dim rear view mirror. I clicked it once and it went dark so I thought the mirror was going to sleep for some reason. Now I know what it's for. Useful when I have a cop tailing me with annoying lights. They don't bother me anymore (^_^)=b.
=Didn't even know.

-I can adjust my seat up and down as well, not only forward and backwards. When I got the car, it had this bar on the side. Didn't even know what it was. I pushed it one day and it automatically when forward. I actually gasped and was wrapped in jizzing excitement that I had a car with automatic seat thing. Later I learned pushing it up and down adjusts seat as well.
=Didn't even know.

-Everyone had P0421/P0431 problems. I had this light on couple months after I bought the car. Took it to dealers and they said it was cat converter blah blah. Told me it's not a big deal and that it will cost couple hundreds to fix. I'm a broke college boy and as they said it doesn't affect my car's safety or performance, I didn't fix it. Way later after joining the club, I found out that I had warranty to fix it, unfortunately, my warranty ran out last year for emission control systems and dealers did not offer to fix it saying they put "CAT CON WARRANTY" on the service record. How the F**K am I supposed to know what that means. I called 5 mits dealers across BC and they all said no because warranty ran out. When I took my car to dealers and they found this problem, I still had the warranty. They could've at least offered to fix or directly told me it was covered instead of writing a small note on my service paper. How many people who does not know a lot about cars will catch this on complicated service paper and ask to be fixed. Anyhow, theres nothing I can do. I erase this dumb thing every 30 minutes now.
=Didn't even know.

-My car had warranty. (or what's left of it). My car has deep rumbling and grinding noise coming when I steer right only and accelerating. Thankfully, I still have powertrain warranty and I am going in tmr to get it checked out. Tomorrow will be my judgment day as if it's not covered, it will cost couple thousands to fix and if that is the case, I'm not going to spend anymore money or care about this car frankly. If it is covered, then I will probably jizz in the store. Make sure to check your car for warranty!
=Didn't even know.

-TPMS problem are common I guess. You only have two options. Pay couple hundred dollars to fix it or but a black tape over it. I hate how my car has check engine light for P0421/31 and TPMS light, but I guess I have to live with it now.
=Didn't even know.

-The forum is still alive! Most of the post were far back from 2010 and up. Not many posts from 2017 or 2016 so I though all these guys are either too old now or moved on to their next car. But nowadays, I still see people joining the club and some posts here and there and that makes me happy.
=It's alive!

There are few more but I can't remember them at the moment. I feel bad as I've only learned things but have not contributed in anything thus far. Hopefully when I figure something out, I can start helping out other members.
danikorea is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old April 17th, 2017, 09:30 PM   #2 (permalink)
Ricer
 
Sabertooth^2's Avatar
 
6 Highscores

Name: James
Join Date: Aug 2015
Location: London
Vehicle: 2009 GS
Posts: 2,509
Rep Power: 0
Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2 Sabertooth^2
-I'm supposed to (?) have two 12v outlet. Some said after 2007, they took it out. I have one by climate control and nothing inside center compartment. Just a black plastic circle cover. Will pop it this week and see if everything is prewired so I can install 2nd 12v outlet. Hope it doesn't drain battery
=Didn't even know.

It's pre-wired on all of them, so you only need the plug. Pull one from a junkyard. Take everything out of the center console, and you'll see a spot on the front of the floor plate that looks like you can pull up on it. Try, and if it pulls up you don't need to remove anything else to install the 12v plug. If it doesn't want to go without breaking, look at my guide on adjusting the e brake cable, it shows how to remove it the long way


-My speedo was off by 10km/hr +. Didn't even know why and didn't try to fix it when I got the car. Now I know it may be due to the 17" rim I have. If not whatever. At least it puts me at ease that many people had same questions about our cars.
=Didn't even know.

What's your tire size? The rim doesn't matter, it's all about overall diameter. If you're running too small a sidewall, it'll read high. Too big, it'll read low


-The forum is still alive! Most of the post were far back from 2010 and up. Not many posts from 2017 or 2016 so I though all these guys are either too old now or moved on to their next car. But nowadays, I still see people joining the club and some posts here and there and that makes me happy.
=It's alive!

These cars are finding their second/third life with new owners in masses now, so it's awesome.



I'm glad you're having a good time here!
__________________
July COTM NOMINATION form
^Keep up to date on Car of The Month here!

My Build Thread
Sabertooth^2 is offline   Reply With Quote Quick reply to this message
Old April 22nd, 2017, 10:20 PM   #3 (permalink)
Member
 

Name: Dan
Join Date: Apr 2017
Location: Vancouver
Vehicle: 2008/Eclipse/GT/3.8L V6
Posts: 41
Rep Power: 1
danikorea is on a distinguished road
Quote:
Originally Posted by Sabertooth^2 View Post
-I'm supposed to (?) have two 12v outlet. Some said after 2007, they took it out. I have one by climate control and nothing inside center compartment. Just a black plastic circle cover. Will pop it this week and see if everything is prewired so I can install 2nd 12v outlet. Hope it doesn't drain battery
=Didn't even know.

It's pre-wired on all of them, so you only need the plug. Pull one from a junkyard. Take everything out of the center console, and you'll see a spot on the front of the floor plate that looks like you can pull up on it. Try, and if it pulls up you don't need to remove anything else to install the 12v plug. If it doesn't want to go without breaking, look at my guide on adjusting the e brake cable, it shows how to remove it the long way


-My speedo was off by 10km/hr +. Didn't even know why and didn't try to fix it when I got the car. Now I know it may be due to the 17" rim I have. If not whatever. At least it puts me at ease that many people had same questions about our cars.
=Didn't even know.

What's your tire size? The rim doesn't matter, it's all about overall diameter. If you're running too small a sidewall, it'll read high. Too big, it'll read low


-The forum is still alive! Most of the post were far back from 2010 and up. Not many posts from 2017 or 2016 so I though all these guys are either too old now or moved on to their next car. But nowadays, I still see people joining the club and some posts here and there and that makes me happy.
=It's alive!

I'm glad you're having a good time here!

Thanks for the reply! Was really helpful!
My center console plate doesn't want to come out unless I break it so looks like I have to go a long way around. I found a plug at Canadian Tire so looks like it will be easy to hook it up. I only hope it doesn't drain the battery.
I'm not too sure with the tire size but will check on it. I have 17" rim with a winter tire on it still. Going to change it to all season since winter is done, sticker on the door says P235/45R18 so I am looking for this size? I guess. Well I need a 18" rim first anyways.
__________________
2008 Mitsubishi Eclipse GT 3.8L V6
danikorea is offline   Reply With Quote Quick reply to this message
Reply

Tags
2007, aftermarket, aux, black, calipers, car, cars, cat, door, exhaust, fix, install, lights, oem, offer, owners, performance, problems, rear, rim, rims, seat, tire, total, wheel

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Frankenstein found! Under my hood 4g64 block and 4g69 components on my 07 Ghosteclipse Eclipse Performance 3 January 24th, 2017 11:23 AM
ISO 4g69 things BMWCHARGERS1 Automotive For Sale/Wanted 1 March 29th, 2016 09:42 PM
A couple things I'd like some input on Ksix50 Problem Reports 8 February 24th, 2016 12:34 PM
Found a scanner to reset airbag light 1raptor 2006-2012 Eclipse (General 4G) 6 October 27th, 2014 07:51 AM


All times are GMT -5. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger