Ecom error with non rf system, new hu? - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Audio & Lighting

Audio & Lighting Head units, subs, amps, caps, neon lighting, LEDs, and anything else that uses a DC power source not tuning related goes here.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old January 25th, 2012, 09:54 PM   #1 (permalink)
Senior Member
 
xtreme4g2012's Avatar
 

Join Date: Nov 2011
Vehicle: 2012/eclipse/gs
Posts: 159
Rep Power: 3
xtreme4g2012 is on a distinguished road
Ecom error with non rf system, new hu?

first off I did search and read up on this, fixing to order a double din, My question is i want to know if i'll get the error with a non rf system in my gs switching to new hu? I did find one post from a guy who asked same question but only one person responded saying shouldnt get the error on a non rf system with new hu, need some comformation on this if anyone can confirm?

before anyone flames i took the appropriate measures and know i need the mito 1 kit or the metra kit, but everybody i saw talking had a gt with the rf system, want to be ready when i receive my double din on what i need to install......
xtreme4g2012 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old January 25th, 2012, 09:57 PM   #2 (permalink)
Senior Member
 
Daxenth's Avatar
 

Name: Jeff
Join Date: May 2010
Location: Twinsburg, Ohio
Vehicle: 2002 Honda S2k
Posts: 14,205
Rep Power: 20
Daxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud of
ill give you this one since weve been raping your butt lately...

there is only one known way to fix the ecom, and thats by buying the special interface harness MIT_01 or some shit. BUT! its rather pricey, and changes the E-Com error to say "MY ECLIPSE" and thats it... personally.. id rather it say ecom and spend my money elsewhere.
__________________

Mods=Daxenth's Satin Girl
Quote:
Originally Posted by Coldsou View Post
I, Panda and Dax, decree that on this Sunday morning, the third generation Eclipse is now revoked of all it's right to be part of the Eclipse family. From now on it is to be known as the "Mitsubishi Stillbirth".
Daxenth is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 09:58 PM   #3 (permalink)
Deceased Member

 
Phantom_4G's Avatar
 
1 Highscore

Name: Will
Join Date: Apr 2009
Location: DMV Metro Area
Vehicle: 2006/Eclipse/GT
Posts: 6,639
Rep Power: 14
Phantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant future
Ooooooh Im bout to flame the SHIT outta you!




Ok i lied...no im not. No as long as ur shart is hooked up right and doesnt have any manufacturer defects then you shouldnt receive and sort of errors.
Phantom_4G is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 09:59 PM   #4 (permalink)
Senior Member
 
freakydeaky's Avatar
 
48 Highscores
Tournaments Won: 4

Name: www.c4gnation.com
Join Date: Jan 2009
Location: On the NATION
Vehicle: 07 GS & 08 GT
Posts: 3,061
Rep Power: 9
freakydeaky is a splendid one to beholdfreakydeaky is a splendid one to beholdfreakydeaky is a splendid one to beholdfreakydeaky is a splendid one to beholdfreakydeaky is a splendid one to beholdfreakydeaky is a splendid one to beholdfreakydeaky is a splendid one to behold
the mito kit will change the error message to "my eclipse" not sure about the metra... so make sure you get the one that will change the error message in case you do get it... if you don't get the error--- no harm no foul
freakydeaky is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 09:59 PM   #5 (permalink)
Deceased Member

 
Phantom_4G's Avatar
 
1 Highscore

Name: Will
Join Date: Apr 2009
Location: DMV Metro Area
Vehicle: 2006/Eclipse/GT
Posts: 6,639
Rep Power: 14
Phantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant futurePhantom_4G has a brilliant future
Quote:
Originally Posted by Daxenth View Post
ill give you this one since weve been raping your butt lately...

there is only one known way to fix the ecom, and thats by buying the special interface harness MIT_01 or some shit. BUT! its rather pricey, and changes the E-Com error to say "MY ECLIPSE" and thats it... personally.. id rather it say ecom and spend my money elsewhere.
I got my MIT-01 from ebay for a goodprice. i forgot what that price was though. it was a while ago
Phantom_4G is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:05 PM   #6 (permalink)
Senior Member
 
xtreme4g2012's Avatar
 

Join Date: Nov 2011
Vehicle: 2012/eclipse/gs
Posts: 159
Rep Power: 3
xtreme4g2012 is on a distinguished road
Axxess MITO-01

Amplifier Interface Harness for Select 2006-2008 Mitsubishi Vehicles with Rockford Fosgate Factory Amplified System






I dont have the rockford fosgate system so wonder if its even needed?! hm
xtreme4g2012 is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:11 PM   #7 (permalink)
Senior Member
 
Daxenth's Avatar
 

Name: Jeff
Join Date: May 2010
Location: Twinsburg, Ohio
Vehicle: 2002 Honda S2k
Posts: 14,205
Rep Power: 20
Daxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud of
its needed... mitsubishi electronics are fucking ridiculous
__________________

Mods=Daxenth's Satin Girl
Quote:
Originally Posted by Coldsou View Post
I, Panda and Dax, decree that on this Sunday morning, the third generation Eclipse is now revoked of all it's right to be part of the Eclipse family. From now on it is to be known as the "Mitsubishi Stillbirth".
Daxenth is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:14 PM   #8 (permalink)
Senior Member
 
xtreme4g2012's Avatar
 

Join Date: Nov 2011
Vehicle: 2012/eclipse/gs
Posts: 159
Rep Power: 3
xtreme4g2012 is on a distinguished road
ok i'll order it when i get ready
xtreme4g2012 is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:15 PM   #9 (permalink)
Senior Member
 
Daxenth's Avatar
 

Name: Jeff
Join Date: May 2010
Location: Twinsburg, Ohio
Vehicle: 2002 Honda S2k
Posts: 14,205
Rep Power: 20
Daxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud ofDaxenth has much to be proud of
i mean feel free to confirm it. i dont have RF shit so i never looked but... like i said. mistu electronics arent something to fuck with
__________________

Mods=Daxenth's Satin Girl
Quote:
Originally Posted by Coldsou View Post
I, Panda and Dax, decree that on this Sunday morning, the third generation Eclipse is now revoked of all it's right to be part of the Eclipse family. From now on it is to be known as the "Mitsubishi Stillbirth".
Daxenth is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:30 PM   #10 (permalink)
Autocityimports Rep

 
OrangeDemon's Avatar
 

Name: Jason
Join Date: Jan 2011
Location: Parma, Ohio
Vehicle: 2006/Eclipse/GT
Posts: 4,521
Rep Power: 8
OrangeDemon is a glorious beacon of lightOrangeDemon is a glorious beacon of lightOrangeDemon is a glorious beacon of lightOrangeDemon is a glorious beacon of light
I'm thinking about ripping that stupid pod out and fabbing something because everyone wants one. i don't need to know the temperature anyway.
__________________


Jason Willis - Mitsubishi Support and Sales Specialist
www.autocityimports.com
2006+ Eclipse Product Page
Jason@autocityimports.com
586-797-9083
OrangeDemon is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 10:37 PM   #11 (permalink)
Senior Member
 
xtreme4g2012's Avatar
 

Join Date: Nov 2011
Vehicle: 2012/eclipse/gs
Posts: 159
Rep Power: 3
xtreme4g2012 is on a distinguished road
any way to retain the blue led under the panel
xtreme4g2012 is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 11:29 PM   #12 (permalink)
SEXUAL TYRANNOSAURUS!!!
 
executive's Avatar
 

Name: Jay
Join Date: Jan 2008
Location: Houston
Vehicle: 07 GT-N Spyder 4.0
Posts: 1,906
Rep Power: 8
executive is a name known to allexecutive is a name known to allexecutive is a name known to allexecutive is a name known to allexecutive is a name known to all
Yes, there is a dash kit that has it. I forgot the name though. Crutchfield had it soo you could search their site.
__________________
executive is offline   Reply With Quote Quick reply to this message
Old January 25th, 2012, 11:45 PM   #13 (permalink)
I got this
 
midnight07GT's Avatar
 

Name: Scott
Join Date: Aug 2011
Location: Pennsylvania
Vehicle: 2007 eclipse gt
Posts: 301
Rep Power: 3
midnight07GT will become famous soon enough
Go to amazon and you'll get the new face plate and wire harness combo for about $130. Which is half the price of the crutchfield setup. but you get what you pay for, my door speakers are fighting with me as we speak.
midnight07GT is offline   Reply With Quote Quick reply to this message
Old January 26th, 2012, 12:02 AM   #14 (permalink)
Selling 4G & Parts.
 
cmattox23's Avatar
 
6 Highscores

Name: Cameron
Join Date: Jun 2010
Location: MD
Vehicle: '07 Eclipse SE
Posts: 2,443
Rep Power: 7
cmattox23 is a name known to allcmattox23 is a name known to allcmattox23 is a name known to allcmattox23 is a name known to allcmattox23 is a name known to allcmattox23 is a name known to all
The e-com error is telling you that your factory RF amp isn't turning on as a result of upgrading your HU. I think if you are non-rf you should be fine, but don't hold me to it. My RF amp not being turned on to power the speakers with more juice than what my Kenwood is providing them bugs me a shit ton more than the e-com message anyway. The integration module enables the HU to turn on the amp and power your speakers in an RF setup.
__________________
Quote:
Originally Posted by kazman View Post
still the car i look up to when it comes to stance


follow me @usversusthem
cmattox23 is offline   Reply With Quote Quick reply to this message
Old January 26th, 2012, 12:04 AM   #15 (permalink)
Got Stance??? i dont :(
 
MFTK's Avatar
 

Name: Dann
Join Date: Apr 2011
Location: LongIsland NY
Vehicle: 2010 Evo X MR
Posts: 1,720
Rep Power: 5
MFTK is a jewel in the roughMFTK is a jewel in the rough
Its $60 for the interface with purchase of deck. On crutchfield n all the wires n faceplate r included
MFTK is offline   Reply With Quote Quick reply to this message
Old October 9th, 2012, 01:53 PM   #16 (permalink)
Junior Member
 

Join Date: May 2008
Vehicle: 2006 Eclipse GT
Posts: 4
Rep Power: 7
Waynerwats is on a distinguished road
Ok I know this is an old post but I read the post and didn't really find an answer. Everything i keep finding points torward a Rockford Fosgate problem. I keep on getting the E Com error but its intermittent. I dont have the Rockford Fosgate system. I did have the head unit replaced under warranty back in 2008. I looked at all the wiring but i can not see anything wrong. Please any help would be greatly appreciated. I like to be able to see what radio station i am switching to if I do switch stations.
Waynerwats is offline   Reply With Quote Quick reply to this message
Old October 9th, 2012, 03:17 PM   #17 (permalink)
AKA DJ FishSticks
 
RD_Chef's Avatar
 

Name: Tom
Join Date: Apr 2010
Location: New Bedford, MA
Vehicle: 2009/Eclipse/GS
Posts: 81
Rep Power: 5
RD_Chef is on a distinguished road
Quote:
Originally Posted by cmattox23 View Post
The e-com error is telling you that your factory RF amp isn't turning on as a result of upgrading your HU. I think if you are non-rf you should be fine, but don't hold me to it.
I won't hold you to it. I was non-RF and I still got the E-COM message. In fact I still have it and I haven't bothered to do anything about it since it doesn't really bother me.
__________________
2009 Mitsubishi Eclipse GS, Maizen Blue Pearl
Audio: Clarion NX-602 Head Unit, Kenwood KAC-8405 Amp, KFC-G6930s in the front and KFC-G1620s in the back.
Mods: K&N Air Filter, TB Spacer, TB Bypass.
RD_Chef is offline   Reply With Quote Quick reply to this message
Old October 12th, 2012, 09:08 AM   #18 (permalink)
Junior Member
 

Join Date: May 2008
Vehicle: 2006 Eclipse GT
Posts: 4
Rep Power: 7
Waynerwats is on a distinguished road
Well if I replaced the factory head unit with an aftermarket one I wouldn't care, but I still use the factory one so I want the screen to work the way it is supposed to.
Waynerwats is offline   Reply With Quote Quick reply to this message
Reply

Tags
install, kit, mito, question, system

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright 2007 - 2013, Club4G.orgAd Management plugin by RedTyger