Did these mods or an idiot kill my engine? - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Do It Yourself Guides (Howto)

Do It Yourself Guides (Howto) HowTos, Technical Data and Documentation for the 4G Eclipse


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old June 16th, 2015, 03:16 AM   #1 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
Did these mods or an idiot kill my engine?

My car started off sexy,2007 2.4. I'll post a better pic of my running car later. I can't stand to look at the pics right now because My engine ended up a mess ? so I need you mod guys to sort some things out for me. This is what we have so far. 3 broken belts....a blown off oil filter. The oil pan was installed wrong and left adhesive chunks in my oil pump which in turn did a lot. Belts, seals, gasgets bent valves. Crank looks ok but that's toss up..I haven't removed the head yet. See pics below. So here's the deal. What do I need to do now about the mods...injens, mikuni idol thing from what I can tell, and others I'm not sure about. I'm still discovering new additions. 3 gaskets on the exhaust manifold?? Is that normal? Yes I'm a newbie but I'm pretty good at this stuff for a girl. The turbo extra stuff not so educated at. I get the idea but.... That is where I need your help. What will this do to my engine? I wish I would of known more about my engine before it blew.
Attached Images
File Type: jpg image_1434441425829.jpg (26.3 KB, 89 views)
File Type: jpg image_1434441936119.jpg (22.6 KB, 91 views)
File Type: jpg image_1434442020618.jpg (24.3 KB, 88 views)
File Type: jpg image_1434442157079.jpg (28.9 KB, 89 views)
File Type: jpg image_1434442286981.jpg (11.3 KB, 82 views)
File Type: jpg image_1434442456511.jpg (21.8 KB, 74 views)
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 16th, 2015, 08:46 AM   #2 (permalink)
No Worries
 
tcsoccer09's Avatar
 

Name: Tim
Join Date: Sep 2010
Location: Louisville, KY
Vehicle: 2009 Eclipse GS Auto
Posts: 3,881
Rep Power: 10
tcsoccer09 is a name known to alltcsoccer09 is a name known to alltcsoccer09 is a name known to alltcsoccer09 is a name known to alltcsoccer09 is a name known to alltcsoccer09 is a name known to all
Wttc Brandy. Sorry you have to join us on these bad circumstances. I can't be of much help as I've never had a major engine problem. I'm sure others will chime in though.
__________________


My Ride Thread: http://club4g.org/board/members-ride...09s-09-gs.html
tcsoccer09 is offline   Reply With Quote Quick reply to this message
Old June 16th, 2015, 02:12 PM   #3 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
Thanks, I'm sorry I'm joining under these circumstances too. I feel like an idiot for not taking the time to know more about these mods before my engine blew. I've researched and I understand that more air plus gas equals= more in general so I need better parts and what not,but it's hard to figure out what gaskets, valves, pistons to buy and if I'm going to have to rebuild I need to get the right parts. And the 2007 seems like a ghost car because finding specs for this car is almost impossible. Except here. And sorry the pics suck.
Brandyseclipse is offline   Reply With Quote Quick reply to this message
 
Old June 16th, 2015, 02:34 PM   #4 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,111
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
From what I'm looking at in your pictures, those look like timing belts... OUCH!!!
There's no easy way of saying this, but I'm betting your engine is toast. This is
a zero clearance engine, belts break, so does your pistons and valves. Clogged
oil filter screen, blowing your oil filter off the engine, all your engine bearings
will be toasted. Blown oil seals, what other seals will be damaged. You are looking
at a complete engine rebuild.

If you are planning to do the rebuild yourself, it will take TIME and MONEY. If you
have never rebuilt a high compression engine before, every detail counts. One
little mistake and you will be at square-one again, a toasted engine. There maybe
other unseen damage that requires repairs, I.E. more $$$$.

Because of inflation, that's my $2.00 worth.

Your best options, buy a used engine with low-miles on it, or buy a rebuilt engine, $700 to $2000.

This is a link to the Eclipse Factory Service Manual, you should find most of your information here.
If you need help navigating the Service Manual, just ask.
2006 Eclipse Factory Service Manual | Tearstone

One little question... how many miles do you have on the car/engine??

Nice looking Eclipse, so sorry about your engine!!
Welcome to Club 4G!!!
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; June 16th, 2015 at 03:02 PM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old June 16th, 2015, 02:34 PM   #5 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
One more thing it's a stick.
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old June 16th, 2015, 03:08 PM   #6 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,111
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Picture 3 of 6 is the intake manifold plenum chamber, with a CAI, or SRI installed on it, or is it the intake from the turbo.
http://club4g.org/board/attachments/...4442020618.jpg

Picture 6 of 6 WARNING: This is your balance shaft pulley (Small Belt), there is one timing make on this pulley... but the mark can be set correctly, or 360 degrees off, on the same timing mark. If you install this pulley 360 degrees off your engine will vibrate above 2000 RPM. You can find the proper settings for this pulley in the service manual. Good info if you are doing a timing belt change!!
http://club4g.org/board/attachments/...4442456511.jpg


Do you have a picture of the turbo setup??
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; June 16th, 2015 at 09:48 PM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old June 17th, 2015, 02:02 AM   #7 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
Hi thanks for your input, yes it is the timing belt and oil seal was twisted on the the oil pump side. Crank bearings actually look pretty good so far but I haven't pulled it all the way out.So far the damage is...... All new seals and gaskets just to be safe. And I'm cleaning and inspect all the rocker arms and pulling the head tomorrow. And I will take better pictures tomorrow of the turbo setup. The timing will be completely reset and I think I have that under control. But I was wondering about deleteing the balance shafts. I get so many mixed reviews.... I'm going to look into what you said above about what those mods are on that you mentioned. The engine is actually really clean. No metal shavings anywhere or anything. I towed it right away and started tearing it apart so I think not much metal if any circulated. Also if there was a blown gasget on the exhaust manifold will that cause a lead color to drip down the crank?there was a small streak on the piston rod cap so I was thinking bearing but it looks good when I took the cap off but We will see ?.... Anyone know what gasket and seal set I should buy? I want to buy them all at once...and any other important 4g details that aren't listed in the vague service manual?
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old June 17th, 2015, 03:00 PM   #8 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,111
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Quote:
Originally Posted by Brandyseclipse View Post
Hi thanks for your input, yes it is the timing belt and oil seal was twisted on the the oil pump side. Crank bearings actually look pretty good so far but I haven't pulled it all the way out.So far the damage is...... All new seals and gaskets just to be safe. And I'm cleaning and inspect all the rocker arms and pulling the head tomorrow. And I will take better pictures tomorrow of the turbo setup. The timing will be completely reset and I think I have that under control. But I was wondering about deleteing the balance shafts. I get so many mixed reviews.... I'm going to look into what you said above about what those mods are on that you mentioned. The engine is actually really clean. No metal shavings anywhere or anything. I towed it right away and started tearing it apart so I think not much metal if any circulated. Also if there was a blown gasget on the exhaust manifold will that cause a lead color to drip down the crank?there was a small streak on the piston rod cap so I was thinking bearing but it looks good when I took the cap off but We will see ?.... Anyone know what gasket and seal set I should buy? I want to buy them all at once...and any other important 4g details that aren't listed in the vague service manual?
You can not delete the balance shaft, without the balance shaft the engine will vibrate badly, and down the road the engine will fail!! Like I posted earlier, the balance shaft can be set two ways on the same timing mark. The way to set the timing mark: Turn the roller 360* and set to timing mark. With just a little pressure try turning the pulley left or right, if the timing mark comes back towards the set timing mark your good. If by using little pressure to turn the pulley left or right, and the pulley timing mark falls away from the set timing mark then you are 360* off. Turn the pulley around to the set timing mark and try again.

Still need to know how many miles was on your car and when the last timing belt change was, if ever done. A turbo setup on any engine would be expected to be extreme engine conditions, and the timing belt needs to be changed every 60,000 miles, or 48 months, period!!

I'm sure if you are going to rebuild your engine, you will want to put the best parts back into your engine. We just found out that the newer Eclipse 2009+ engines uses a new timing belt that can go 105,000 miles between changes, so as far as timing belt goes (both timing belts, tensioner adjuster, water pump and any pulleys), stay with OEM Parts!! I would also say stay with OEM gasket set also.

As far as other internal parts, I'll have to turn you over to other members who have done resent engine rebuilds on their engines.

For your exhaust manifold gasket I recommend "Remflex Exhaust Gaskets".
1-866-641-7325, www.remflex.com ~ I know the have the exhaust gasket for our 3.8 V-6, because I had them made for us. I'm very sure another member here had them made for the 2.4 4cyl. ($45). I have them installed on my RIPP LT headers and have had zero problems with them in-fact I still have two un-open sets of these gaskets on hand. Highly recommend this product, they are not you average gasket, they are high-performance, for racing applications. They can also handle heat soak up to 3000*, perfect for a turbo setup.

All oil journals need to be flushed for contamination before rebuild starts.
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; June 17th, 2015 at 03:07 PM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old June 17th, 2015, 03:16 PM   #9 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,111
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Just a simple vids on timing belt change for the 2.4L engine by a real Mitsubishi Mechanic.

https://www.youtube.com/watch?v=N_VyXb12MBA

Eclipse Factory Service Manual Link: Or, welcome back to college, we'll be studying the 4G Eclipse in detail!!
http://tearstone.com/2006-eclipse-fa...ervice-manual/

Just a few books to start reading.

GROUP 11A ENGINE MECHANICAL 2.4L ENGINE
http://tearstone.com/eclipsefsm/2006...000500-11A.pdf

GROUP 11B ENGINE OVERHAUL 2.4L ENGINE
http://tearstone.com/eclipsefsm/2006...004800-11B.pdf

GROUP 13A MULTIPORT FUEL INJECTION (MFI) 2.4L ENGINE
http://tearstone.com/eclipsefsm/2006...05800A-13A.pdf
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; June 17th, 2015 at 03:26 PM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old June 18th, 2015, 10:44 AM   #10 (permalink)
Member
 

Name: brad
Join Date: Jan 2015
Location: tucson
Vehicle: 2007 spyder gt
Posts: 36
Rep Power: 3
poptones is on a distinguished road
Quote:
Originally Posted by Brandyseclipse View Post
Hi thanks for your input, yes it is the timing belt and oil seal was twisted on the the oil pump side. Crank bearings actually look pretty good so far but I haven't pulled it all the way out.So far the damage is...... All new seals and gaskets just to be safe. And I'm cleaning and inspect all the rocker arms and pulling the head tomorrow. And I will take better pictures tomorrow of the turbo setup. The timing will be completely reset and I think I have that under control. But I was wondering about deleteing the balance shafts. I get so many mixed reviews.... I'm going to look into what you said above about what those mods are on that you mentioned. The engine is actually really clean. No metal shavings anywhere or anything. I towed it right away and started tearing it apart so I think not much metal if any circulated. Also if there was a blown gasget on the exhaust manifold will that cause a lead color to drip down the crank?there was a small streak on the piston rod cap so I was thinking bearing but it looks good when I took the cap off but We will see ?.... Anyone know what gasket and seal set I should buy? I want to buy them all at once...and any other important 4g details that aren't listed in the vague service manual?
I'm an old dude, so this is unusual to me. When I was young and dating my ex, she had a best friend who loved cars. The girl was 16 and had a mopar in the driveway she and her father had built together. I should have kicked the ex to the curb and dated the friend.

Rock on, Brandy.

Is this your primary car? Why not buy a donor and swap engines, then you can rebuild your present engine as you get the money for very good parts?
poptones is offline   Reply With Quote Quick reply to this message
Old June 22nd, 2015, 03:23 AM   #11 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
Hi guys thanks for your help!!! And part recommendations. I will keep balance shafts. Milage is 100,000 give or take and don't know about the belt because im the second owner and I should of done it before just to be safe. I pulled the head, all by myself ? and found some very nasty carbon and bent valves. Also it is my preference to drive this car but I have 3 others so I have transportain so I can take my time as long I have this little bitch on the road by August. I don't want to buy a used engine if mine isn't warped or completely shot. Id rather replace valves, all seals and gaskets and the rest is easy breezy. If the pistons, bearings and everything else important is shot I will do a swap, then rebuild my engine and go from there. I agree it is unusual for a girly girl like me to tear an engine apart but when you love your eclipse I think you will do just about anything!!!! I learned fast, rolled up my sleeves and got dirty....
Attached Images
File Type: jpg image_1434961022573.jpg (34.6 KB, 23 views)
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old June 22nd, 2015, 03:36 AM   #12 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
I did a leak down, as I suspected intake valves are shot but I knew by measuring up top. I cleaned my rocker arms today that sucked ass. But that's all good and camshaft journal is all at spec so that is positive. I'll update after I inspect the rest. Pray for me!!!! also just in case I need to do a swap, if anyone in my area knows of a place to get a used engine in the Tacoma/Seattle area that would be great. I checked at a few auto wrecking yards but that was a joke. Thanks 4g buddies!!! Maybe you guys know someone who knows someone
Attached Images
File Type: jpg image_1434961717321.jpg (26.4 KB, 20 views)
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old June 23rd, 2015, 04:19 AM   #13 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
Head isnt warped but these valves have seen better days and I tore it apart in my sunroom. Bad valves good sunny day for engine investigations
Attached Images
File Type: jpg image_1435051111424.jpg (32.4 KB, 27 views)
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old June 23rd, 2015, 04:25 AM   #14 (permalink)
Junior Member
 

Name: Brandy
Join Date: May 2015
Location: Tacoma
Vehicle: 2007 eclipse se
Posts: 9
Rep Power: 3
Brandyseclipse is on a distinguished road
This is kinda cool for part numbers... Don't know if I will be using any of them but it's a good reference http://www.mitsubishipartswarehouse....w=11&maxRow=10
Brandyseclipse is offline   Reply With Quote Quick reply to this message
Old August 5th, 2015, 01:32 AM   #15 (permalink)
Member
 

Name: Tahir
Join Date: May 2014
Location: Atl
Vehicle: 2006 eclipse
Posts: 30
Rep Power: 4
Tahir1983 is on a distinguished road
Just found ur post today and was curious to know if u got ur car working again?
Tahir1983 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
gs hydrolocked engine calitin Problem Reports 36 February 28th, 2015 12:12 PM
FS: mivec engine partout msoto Automotive For Sale/Wanted 73 January 19th, 2015 10:46 AM
FS: FS NY: Misc GT Engine Parts and More trevroar Automotive For Sale/Wanted 17 January 7th, 2015 03:47 PM
Help me prioritize! ModgePodge 2006-2012 Eclipse (General 4G) 15 October 28th, 2014 07:38 PM
2006 eclipse engine shaking, smell of burnt, and wants to stall Nayla Problem Reports 3 August 9th, 2014 09:29 AM


All times are GMT -5. The time now is 10:31 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger