Car won't start..? - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > General > Problem Reports

Problem Reports If you have a problem with your Eclipse you need assistance with, this is the forum to post your question and get answers.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old July 17th, 2015, 08:25 AM   #1 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
Car won't start..?

Hey guy I need help ,,, my car run nice but when I try to start in the morning it won't start .. Power stii good when I turn the key it felt like it gonna start but no .. Anybody have the same problem if not please help me out thanks appreciate first
CuTi08 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old July 17th, 2015, 08:51 AM   #2 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Quote:
Originally Posted by CuTi08 View Post
Hey guy I need help ,,, my car run nice but when I try to start in the morning it won't start .. Power stii good when I turn the key it felt like it gonna start but no .. Anybody have the same problem if not please help me out thanks appreciate first
Is the check engine light on??

Have you checked your OBDII for codes.
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/


Clovisman is offline   Reply With Quote Quick reply to this message
Old July 17th, 2015, 11:27 PM   #3 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
Quote:
Originally Posted by Clovisman View Post
Is the check engine light on??

Have you checked your OBDII for codes.
it on then it go away ,, yes i did but couldn't remember wat it say sorry guys ,, but all i know is that the car want to start when you turn on the keys but it not start .. so i will try to replace all spark plugs and spark wire ( coil) and see wat happen ... if still not work i mite change the Fuel injection .. hope it work .. if any idea to make my car work ( start again ) I'm a happy man ...
CuTi08 is offline   Reply With Quote Quick reply to this message
 
Old July 18th, 2015, 12:34 AM   #4 (permalink)
1st Turbo 4g In Colorado
 
DeAtHsWhIpLaSh's Avatar
 

Name: David
Join Date: Sep 2010
Location: Colorado
Vehicle: 2009/Eclipse/GST
Posts: 329
Rep Power: 7
DeAtHsWhIpLaSh will become famous soon enough
listen and see if you can hear the fuel pump prime when you turn the key to the on position? might be your fuel pump
DeAtHsWhIpLaSh is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 01:45 AM   #5 (permalink)
Senior Member
 

Name: Alexander
Join Date: Feb 2014
Location: Lloydminster AB
Vehicle: 2007 Eclipse GS
Posts: 199
Rep Power: 4
EPOCLIPSE777 is on a distinguished road
Sounds like a starter selinoid. And you really need to figure out your codes before you start waistin you money on parts
EPOCLIPSE777 is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 05:24 AM   #6 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold


There are many things that can cause a no start condition:

Jumped timing belt.

Bad cam, or crank shaft sensor/s.

MAF/IAT sensor.

Fuse-able Link on battery.

Throttle body sensor/s

Any number of sensor that control ignition.

Injection Harness

spark-plugs

Coil Packs

Fuel Pump

So if you just start changing parts out, it'll will cost you upwards of $2000, and you still might not find out what your problem is.

You need to start with OBDII codes first.

How many miles do you have on your vehicle?

Was your timing belts ever changed?
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; July 18th, 2015 at 05:37 AM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 08:20 AM   #7 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
On the OBD2 al I remember is engine misfire , mechanical issue , air leak ..it one more but couldn't remember .. It park far now one my work done and I got time I'll take spark pig and wire ( ignition coil) out and check ... Thanks
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 08:46 AM   #8 (permalink)
Senior Member
 
Flaboy806's Avatar
 

Name: Chris
Join Date: Feb 2015
Location: Saint Petersburg fl
Vehicle: 06 eclipse
Posts: 886
Rep Power: 3
Flaboy806 will become famous soon enough
A misfire doesn't deff mean it's your plugs or coils a vacuum leak could cause this as well how many miles are on the car?


Sent from AutoGuide.com Free App
Flaboy806 is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 09:14 AM   #9 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Quote:
Originally Posted by Flaboy806 View Post
A misfire doesn't deff mean it's your plugs or coils a vacuum leak could cause this as well how many miles are on the car?


Sent from AutoGuide.com Free App
I think I read somewhere he was around 62K.

Unless someone cleared these codes, they will still be logged and you can pull the codes with a OBDII Code Reader. You can buy an OBDII Code Reader from $25 to $50 at any auto parts store. This is not wasted money as it will be used many times in your life time.

Misfires can be caused from so many things, from bad sensors, jumped timing belt/s, vacuum leak, bad spark plugs, injectors, harnesses, coil pack, so important to have actual codes!!
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; July 18th, 2015 at 09:18 AM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 11:05 AM   #10 (permalink)
Senior Member
 
Flaboy806's Avatar
 

Name: Chris
Join Date: Feb 2015
Location: Saint Petersburg fl
Vehicle: 06 eclipse
Posts: 886
Rep Power: 3
Flaboy806 will become famous soon enough
At 62k I'm not gonna say it can't be your plugs or coils cause it could but chances are it's not these items usually last much longer I would try to retreats the codes so we can further help you


Sent from AutoGuide.com Free App
Flaboy806 is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 12:11 PM   #11 (permalink)
Member
 

Join Date: Feb 2011
Posts: 36
Rep Power: 7
viller is on a distinguished road
Check your timing belt. easy way take your oil cap off look into the hole you will see your valves and rockers.

Have another person sit in the car turning the ignition to crank.if they just "Bump" the key. you can look into the oil fill hole and see if you see any of the rockers moving. if not moving then you have a stripped or broken timing belt.

I own three 4gs I had 2 belts break in the same month they are good for 60k miles and believe me you do not want to chance breaking it.

One I was really lucky and just needed a new timing belt 300 at stealership the other I had to get the head reworked 1400 at random shop.

~viller
viller is offline   Reply With Quote Quick reply to this message
Old July 18th, 2015, 11:33 PM   #12 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
i don't have time to fix it my shelf and i wonder how much if bring out to the shop .. having got it done in the shop before so i don't wat it cost ..?? any rough # so i can get it fix i hate to see my Baby park a side ....
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 19th, 2015, 07:35 AM   #13 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
First we would have to T-shoot your problem so we know what part/s might need to be replaced. So to give a safe estimate... ????

Have you found out what is wrong yet??
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/


Clovisman is offline   Reply With Quote Quick reply to this message
Old July 19th, 2015, 11:38 PM   #14 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
Quote:
Originally Posted by Clovisman View Post
First we would have to T-shoot your problem so we know what part/s might need to be replaced. So to give a safe estimate... ????

Have you found out what is wrong yet??
no not yet .. i having start T-shoot yet . i'm to busy try to get my business up and running i don't have time to play with it ..
At this point i just need to replace some good Spark Plug and some and spark wire seen it having been change seen the day i bought the car .. it been 62k already so not a bad idea to change it i guess .. also i need to get my bottom 2 02 sensor place with a new adapter the one came with it got bad won;t hold the in place ..... if do all that won't fix it then i just change the timing belt and water pump just to be on the safe side .... but once i bring to the shop o hope they can fine wat wrong with it before i let them fix ..

but thanks alot guys ,,. at lease i having an idea wat mite be wrong with my car ..
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 20th, 2015, 01:37 AM   #15 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Sorry we couldn't help you out more Chris, but I know you have a lot on your hands right now.

But at least do Viller's quick check on the timing belt by looking at the valve train:

Timing belt check. Take oil cap off look into the hole you will see your valves and rockers. Have another person bump the ignition to crank, but do not start engine. Looking into the oil fill hole, see if your rocker arms are moving. If not moving then you have a stripped or broken timing belt.
~viller

This check will only take 5 minutes, all visual, and no tools required. Well a flash light, or cell phone flash light would help seeing down the oil filler hole.
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/


Clovisman is offline   Reply With Quote Quick reply to this message
Old July 20th, 2015, 11:45 PM   #16 (permalink)
Senior Member
 

Name: Alexander
Join Date: Feb 2014
Location: Lloydminster AB
Vehicle: 2007 Eclipse GS
Posts: 199
Rep Power: 4
EPOCLIPSE777 is on a distinguished road
Quote:
Originally Posted by viller View Post
Check your timing belt. easy way take your oil cap off look into the hole you will see your valves and rockers.

Have another person sit in the car turning the ignition to crank.if they just "Bump" the key. you can look into the oil fill hole and see if you see any of the rockers moving. if not moving then you have a stripped or broken timing belt.

I own three 4gs I had 2 belts break in the same month they are good for 60k miles and believe me you do not want to chance breaking it.

One I was really lucky and just needed a new timing belt 300 at stealership the other I had to get the head reworked 1400 at random shop.

~viller
Holy that's crazy. One of them just broke over night? I honestly am shocked by that. Never thought they would ! Yeah i couldn't imagine the feeling if my mivec ever kissed the valves lol
EPOCLIPSE777 is offline   Reply With Quote Quick reply to this message
Old July 20th, 2015, 11:53 PM   #17 (permalink)
Senior Member
 

Name: Alexander
Join Date: Feb 2014
Location: Lloydminster AB
Vehicle: 2007 Eclipse GS
Posts: 199
Rep Power: 4
EPOCLIPSE777 is on a distinguished road
Quote:
Originally Posted by CuTi08 View Post
no not yet .. i having start T-shoot yet . i'm to busy try to get my business up and running i don't have time to play with it ..
At this point i just need to replace some good Spark Plug and some and spark wire seen it having been change seen the day i bought the car .. it been 62k already so not a bad idea to change it i guess .. also i need to get my bottom 2 02 sensor place with a new adapter the one came with it got bad won;t hold the in place ..... if do all that won't fix it then i just change the timing belt and water pump just to be on the safe side .... but once i bring to the shop o hope they can fine wat wrong with it before i let them fix ..

but thanks alot guys ,,. at lease i having an idea wat mite be wrong with my car ..
I hope you didn't crank the fuck out your engine. Check for loose hoses on your intake manifold and such. I don't know if soap would really help to find an vacuum leak. I never tried lol. Been a diesel tech all I get is forced induction. Run your fingers over it. Could be break booster too
EPOCLIPSE777 is offline   Reply With Quote Quick reply to this message
Old July 22nd, 2015, 12:57 AM   #18 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
the code is P0300 .. thanks for all the idea and helps .. i can get .. once my business is up and running i will get down and dirty to play with .. i can't not let this baby down it the car that get me the girl in my dream as my Wify now and the car that bring my lil man closer so it importing car for us now not just me any more ...
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 22nd, 2015, 01:24 AM   #19 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
P0300 Random/multiple cylinder misfire detected P.13A-531 Sorry this book contains a Broken Link >>>
To view this information you will need to down load the Eclipse Factory Service Manual. The Down-Load Link
is located at the top of the Eclipse Factory Service Manual Page.

2006 Eclipse Factory Service Manual | Tearstone
Offline Download
2006 Eclipse FSM Full Download

Once downloaded, unzip the file, this will make a folder for you with all 71 PDF files for the Eclipse Factory Service Manual.
You will need a PDF Viewer, or Adobe Acrobat to read files. You will find the information in PDF GR00005800C-13A, Page 13A-531.

Brief Description of your Problem:

DTC P0300: Random/Multiple Cylinder Misfire Detected
CAUTION:
If DTC P0300 has been set, TCL related DTC U1120 is also set. After P0300 has been diagnosed, don't forget to erase DTC U1120.

TECHNICAL DESCRIPTION
•If a misfire occurs while the engine is running, the engine speed changes for an instant.
•The ECM or the PCM checks for such changes in engine speed.
.
DESCRIPTIONS OF MONITOR METHODS:
Monitor angular acceleration of crankshaft and detect malfunction when negative variation of the angular acceleration is large.
.
MONITOR EXECUTION:
Continuous
.
MONITOR EXECUTION CONDITIONS (Other monitor and Sensor)
Other Monitor (There is no temporary DTC stored in memory for the item monitored below)
(The sensor below is determined to be normal)
•Camshaft position sensor
•Mass airflow sensor
•Engine coolant temperature sensor
•Intake air temperature sensor
•Barometric pressure sensor
•Throttle position sensor

TROUBLESHOOTING HINTS (The most likely causes for this code to be set are)
•Ignition system related part(s) failed.
•Poor crankshaft position sensor.
•Incorrect air/fuel ratio.
•Low compression pressure.
•Skipping of timing belt teeth.
•EGR system and EGR valve failed.
•ECM failed.
•PCM failed.


I hope you understand why it is so important for us to have the SES code/s to help you.
This is the basic information, there is more technical information to view if you download
the manual, but this is a good snapshot of your problem/s for your misfire.

Last edited by Clovisman; July 22nd, 2015 at 01:57 AM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old July 26th, 2015, 01:02 AM   #20 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
i did have a little bit of time to take a look in the engine ,, i try to start and look in the oil cap but i have that crank but nothing moving in the engine at all ..
so i guess it there nothing i can do i home .. but have to bring to the Shop ...
Please Advises me wat to do or check first before i bring to the shop Hope to learn and fix the Problem .. Thanks a lot guys i mean it ...
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 26th, 2015, 11:18 AM   #21 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Okay, now that you have followed Villars quick check were on person bumps the ignition key, while the other looks down the oil cap hole to confirm movement or not of the valve train/rocker arms, from what you are saying there is "NO" movement of said parts.

This indicates your timing belt/s have broken or slipped. Normal time change for the belts are at 60,000 miles, or every 4 years. Seeings how your timing belt is 8 years old, it could have easily failed because of age.

Now for the bad news. We have a high-compression engine with zero clearance, when the belt/s breaks, so does the engine. Without proper timing the valve will contact the engine pistons causing damage to both the valves and piston heads.

You don't sound like a backyard mechanic that is able to tear into an engine and put it back together again. Not all of us can do a job like this ourselves, without extensive help, I.E. someone with experience, there with you to remove the head to have it repaired, along with any other damage, replace the timing belts correctly, along with putting everything back together.

Depending on damage, to have a certified mechanic to do this job for you, you are looking at between $1200 to $1500. I can not stress to you... Find a good Mitsubishi Mechanic!! Just because the sign says we do auto repairs, this does not mean they know how to blow their nose. Many members on this site will testify to that... It's very hard to fine a good mechanic, make sure you get a written estimate, and a written Warranty for the work to be performed!!

We wish you luck, and if you have any other questions, by all means ask Chris.
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/


Clovisman is offline   Reply With Quote Quick reply to this message
Old July 26th, 2015, 11:54 PM   #22 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
thanks alot at least i know were I'm got my self into .. and i'm really appreciate for any info and time to help me out //
CuTi08 is offline   Reply With Quote Quick reply to this message
Old July 27th, 2015, 08:52 AM   #23 (permalink)
Member
 

Join Date: Feb 2011
Posts: 36
Rep Power: 7
viller is on a distinguished road
Sorry to hear that mate.

I have had Two belts break on me. one I got lucky for 500+60 at stealership. the other bent all my valves up that one cost me about 1400.

Make sure you take it to a shop that you trust. The work the dealer did was shotty. Bolts missing /replaced and I had to take it back because they did not torque the cam shaft position sensor back down. They charged me 60.00 to fix there mess up!

$60 was not enough to fuss about at the time. If they care to loose my future business over 60 bucks then so be it.

~Viller


Quote:
Originally Posted by CuTi08 View Post
i did have a little bit of time to take a look in the engine ,, i try to start and look in the oil cap but i have that crank but nothing moving in the engine at all ..
so i guess it there nothing i can do i home .. but have to bring to the Shop ...
Please Advises me wat to do or check first before i bring to the shop Hope to learn and fix the Problem .. Thanks a lot guys i mean it ...
viller is offline   Reply With Quote Quick reply to this message
Old July 27th, 2015, 09:51 AM   #24 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
LOL!! $60 for fixing their mistake!! I would have told them if they gave me $60 bucks, I wouldn't report them to the BBB, nor the State that licences auto repair shops and mechanics, and for $100 bucks you wouldn't put an add in the news paper for the crappy work they perform. Then tell them that if you take this to small claims court you could recover the full price of the repairs and them some. But I understand, sometimes you just don't want to deal with fools, just get me out of here as quick as possible.

I've had a few bad dealings with repair shops, and when I corrected them, they were more then helpful to solve my problem/s. The same goes when they tell you that you have a bad part and it doesn't fix the problem. Hey, put the old part back in and I'll take it to someone that know what they are doing!! That's why it is very import to get a written estimation, and that you must be notified before any deviations.
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/



Last edited by Clovisman; July 27th, 2015 at 09:55 AM.
Clovisman is offline   Reply With Quote Quick reply to this message
Old August 9th, 2015, 09:41 PM   #25 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
i finally have to to get it to the shop to replace my belt it about 500 that if the nothing bent or out of place .. seen my car it park when it happen so i hope it not so bad then i think it is .. does any of you guys know where to get a Hi Flow CAT that fit well with the GS ..
CuTi08 is offline   Reply With Quote Quick reply to this message
Old August 10th, 2015, 06:39 AM   #26 (permalink)
Senior Member
 
Clovisman's Avatar
 

Name: John
Join Date: Oct 2008
Location: Clovis, NM
Vehicle: 2007 Eclipse GT
Posts: 4,110
Rep Power: 13
Clovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to beholdClovisman is a splendid one to behold
Quote:
Originally Posted by CuTi08 View Post
i finally have to to get it to the shop to replace my belt it about 500 that if the nothing bent or out of place .. seen my car it park when it happen so i hope it not so bad then i think it is .. does any of you guys know where to get a Hi Flow CAT that fit well with the GS ..
I can't remember, but do you have headers?? If not, why do you need a high-flow CAT??

Glad to see you are get your Eclipse in for repairs !!
__________________
Learn, Repair, Trouble-Shoot, Maintain Your Eclipse GT/GS Like New!!
Have a problem with your Eclipse, find the fix at Tearstone:

The 2006-2012 Eclipse Factory Service Manual Link:
http://tearstone.com/2006-eclipse-fa...ervice-manual/


Clovisman is offline   Reply With Quote Quick reply to this message
Old August 12th, 2015, 05:29 PM   #27 (permalink)
Senior Member
 

Name: Chris
Join Date: Oct 2012
Location: Norfolk, NE
Vehicle: 07 Eclipse GS
Posts: 162
Rep Power: 5
CuTi08 is on a distinguished road
yes i have a header .. just give it a better flow and i guess ..my hope right now is that after got my GS Fix and start looking in to the Turbo system part and i know is a pains to get it together and hope the fellow GS that got the System can help me out were to get all the part .... i want to turbo the car it not for race to anything just like the kick out of and challenge my self how far i can go with out empty my bank accounts ..
CuTi08 is offline   Reply With Quote Quick reply to this message
Reply

Tags
art, car, good, i need help, ice, key, need help, power, problem, start

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed timing belt, know car won't start. No fuel or spark. ElQuickness Problem Reports 16 March 30th, 2015 12:02 AM
Help! doing maintainence, now car will not start. Cljviking19 Problem Reports 4 March 5th, 2015 11:19 AM
Help my car wont start Jh3rnandez 2006-2012 Eclipse (General 4G) 2 March 3rd, 2015 01:30 AM
Help, car wont start! kneehurts Problem Reports 3 January 11th, 2015 10:43 AM
installed obx, cant start car soulkilla 4G Eclipse GT/SE Specific 8 October 17th, 2014 08:37 PM


All times are GMT -5. The time now is 06:32 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger