I have a question Radio/Clock display only half-working. Repair or replace? - Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority
Support Our Troops!         
 

Go Back   Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority > Performance and Technical > Tuning and Electronics

Tuning and Electronics This forum is for tuning devices for the 4g eclipse from piggyback systems to full Stand Alones, Fuel Controllers, EGT readings, Data logging, PCM tuning, Air/Fuel readings and data. Discussions of Installations, Wiring & Tuning.


Welcome to the Club4G Forums where you can join fellow owners from all over North America discussing anything related to the 2006+ Mitsubishi Eclipse. You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. To gain access to post topics, communicate privately with other members (PM), respond to polls, upload content, you must register today!

  • Participate in over 100 specialized forums!
  • Get event information regarding meets, mod days and help in our regionalized forums.
  • Gain access to our classified marketplace to buy, sell or trade parts.
  • Levarage a vast collection of Do-It-Yourself guides on steps on working on your Eclipse
  • Access to the growing online parts directory which gives you insight on available parts and the vendors that carry them.
  • Communicate privately with other owners.

All of this and much more is available to you absolutely free when you register for an account. Sign up today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
LinkBack Thread Tools Display Modes
Old June 28th, 2016, 11:19 AM   #1 (permalink)
0 - 60 Eventually
 
Desert Rat's Avatar
 

Name: Andy
Join Date: Jun 2016
Location: Tempe, Arizona
Vehicle: 06 GT Manual
Posts: 848
Rep Power: 1
Desert Rat is just really niceDesert Rat is just really niceDesert Rat is just really nice
Question Radio/Clock display only half-working. Repair or replace?

Hello 4G

I just recently bought my first eclipse and I'm going through the list of various problems that need fixing.

One of the biggest things thats bothering me is the radio/clock display only shows half the digits, like so...


(sorry for poop quality)

A coworker told me that the screen is just loose and to push in the corners. I tried that but to no avail. Sometimes if I don't turn on the radio/CD player when I start up the car, it works fine. But the second I turn it on everything goes all jumbled.

Is there a fix for this? Or do I have to buy a whole new unit? I know most people would just say buy a whole new head unit to replace it, but if I can keep the original system without it being too expensive, I'd like to.

Thanks!
Desert Rat is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old June 28th, 2016, 05:15 PM   #2 (permalink)
Senior Member
 
ryguy's Avatar
 

Name: Ryan
Join Date: May 2007
Location: NH
Vehicle: 06Eclipse Gs
Posts: 1,386
Rep Power: 11
ryguy is a name known to allryguy is a name known to allryguy is a name known to allryguy is a name known to allryguy is a name known to allryguy is a name known to all
I'm gonna check to see if I still have a spare one laying around...You can have it if I do...just pay shipping...

but have you poped off the cover/clock trim to look at it yet?
I think theres a ground wire just under there, maybe check that 1st...
(just grab the top plastic piece and pull it out, itll pop off, and youll see the screws for it and the ground wire.)

Do you have a aftermarket radio installed?
__________________
custom made 4g eclipse flip keys here:
http://club4g.org/board/automotive-s...-evo-vw-8.html
ryguy is offline   Reply With Quote Quick reply to this message
Old June 28th, 2016, 06:16 PM   #3 (permalink)
0 - 60 Eventually
 
Desert Rat's Avatar
 

Name: Andy
Join Date: Jun 2016
Location: Tempe, Arizona
Vehicle: 06 GT Manual
Posts: 848
Rep Power: 1
Desert Rat is just really niceDesert Rat is just really niceDesert Rat is just really nice
Quote:
Originally Posted by ryguy View Post
I'm gonna check to see if I still have a spare one laying around...You can have it if I do...just pay shipping...

but have you poped off the cover/clock trim to look at it yet?
I think theres a ground wire just under there, maybe check that 1st...
(just grab the top plastic piece and pull it out, itll pop off, and youll see the screws for it and the ground wire.)

Do you have a aftermarket radio installed?
If you had a spare, I'd be more than willing to pay for shipping, and throw a lil something your way for your trouble! I get payed next Tuesday on the 5th. Keep me updated!

I do not have an aftermarket, and I'd like to keep the stock 6-disc. I was going to take the clock apart and have a look sometime soon. I cant today but but maybe tomorrow, or this weekend at the latest. I think its heat damage, honestly. I doubt the previous owner(s) used a sun shade at all, and that 110+ heat is beating directly on the top of the unit.

Thank you for your reply! I was afraid no one would see this thread...
Desert Rat is online now   Reply With Quote Quick reply to this message
Reply

Tags
art, buy, car, cd player, clock, display, eclipse, head, head unit, list, original, problems, radio, repair, replace, shows, start, start up, system, uni, working, works

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Club4G Forum : Mitsubishi Eclipse 4G Forums - 2006-2012 Eclipse Authority forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Real Name
What name do you go by?
Location
Where you live.
Type of Car
Year/Model/Trim
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:55 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Ad Management plugin by RedTyger